Forum Donations
Search
VTF Google Search
 Click Here

xv500 1983/84 front brake issue

  • Advertisement

Post a reply

xv500 1983/84 front brake issue

PostAuthor: Gimptank » Mon Jun 11, 2018 10:24 am

hi all

just a question to see if anybody has a bunch.

I am resurrecting a bike that's been stored since 2000. its now running, all fluid has been changed. brakes on the front will grab and hold when u roll the bike backwards.
slides fine going forward.

I realize its not been used in almost 20 years, and I will be putting new brakes on at some point. jyst curious if maybe there is something else I shouls look at before i assume anything.

thanks in advance.

Gimptank
Brand New
Brand New
 
Posts: 3
Joined: Mon Jun 11, 2018 10:17 am
  Flag
Bike year & model: 1983/84 Virago XV500
Sex: Male

Re: xv500 1983/84 front brake issue

PostAuthor: gigafunk » Mon Jun 11, 2018 1:29 pm

I'm new here, but maybe swap the pads from left to right side( if they are the same) and maybe they work right and break it the new direction?

gigafunk
Brand New
Brand New
 
Posts: 3
Joined: Sun Feb 18, 2018 1:23 pm
Location: Los Angeles, CA Flag
Bike year & model: 1983 Virago xv500k
Sex: Male

Re: xv500 1983/84 front brake issue

PostAuthor: Gimptank » Mon Jun 11, 2018 9:20 pm

i went and had a look. they are identical pads, just has a wear indication clip on the piston side pad which can be removed and put on the other side. however because of the little grooves that have been worn into the pads and the rotor (and i not talking mountains just normal wear) i decided to leave the alone..

after i reassembled the pads and whatnot, EUREKA.. now it binds in both directions... which leads me to believe that the piston is not releasing or whatever inside the caliper and i just made it obvious by moving the parts and messing with it. originally, i had to bleed the line because there was no pressure whatsoever, and i found a bit of air in the brake system. after i did that i felt pressure, but it was still binding in reverse direction.

so far i have been able to get to where i am and only having to purchase a new battery and plugs. might be looking for some brake parts soon. hopefully it is just in need of some tlc and can be cleaned. off to youtube.

Gimptank
Brand New
Brand New
 
Posts: 3
Joined: Mon Jun 11, 2018 10:17 am
  Flag
Bike year & model: 1983/84 Virago XV500
Sex: Male

Re: xv500 1983/84 front brake issue

PostAuthor: CycloneFish » Mon Jun 25, 2018 4:50 am

I am in same situation, my bike been sitting for 20 years, now am restoring it. Front disc brake caliper has always been pain in a$$ even before, while it was running. Now i am rebuilding the caliper but piston is stuck and i been struggling pull it out so i can clean it.
Past, Present & Future: RD350 & XV750
User avatar
CycloneFish
Junior Membership
Junior Membership
 
Posts: 7
Joined: Sat Jun 09, 2018 2:45 am
  Flag
Bike year & model: 1981 xv750 Special
Sex: Male

Re: xv500 1983/84 front brake issue

PostAuthor: faffi » Mon Jun 25, 2018 6:30 am

For your own safety, you should strip both the brake master and caliper and at the very minimum inspect all seals and clean everything out. Especially the grove where the brake piston seal sits in the caliper needs to be spotless. Fitting new seals and pistons is recommended, but I have reused old parts that looked flawless in a pinch.

By the sound of your description, your problem is likely a blocked return hole in the master cylinder and/or a semi-frozen piston. Anyway, a strip, clean and inspection will reveal the trouble area.
User avatar
faffi
Silver Membership
Silver Membership
 
Posts: 2699
Images: 10
Joined: Sun Feb 15, 2015 3:11 pm
  Flag
Bike year & model: 1982 XV750SE with XV1100 engine, XT600Z shock absorber, 18" Seca rear wheel
Sex: Male



Post a reply


  • Advertisement

Return to Yamaha Virago XV500

Who is online

Registered users: Baidu [Spider], CycloneFish, Flyingdog, Google [Bot], gs58, JHogg419