Forum Donations
Search
VTF Google Search
 Click Here

Need help with my xv920

  • Advertisement

Post a reply

Need help with my xv920

PostAuthor: Mega778 » Fri Sep 11, 2020 12:20 am

went to start the bike this morning, put the key in the ignition and nothing....no lights or anything. Turned igntion off. Checked battery, voltage was 15.3 Checked connections, didn't see anything unusual.

Turned ignition on again, after a couple minutes all of the lights, blinkers started flashing.

Any ideas?

Mega778
Junior Membership
Junior Membership
 
Posts: 7
Joined: Fri Sep 11, 2020 12:09 am
Location: British Columbia Flag
Bike year & model: 1982 yamaha virago xv920
Sex: Male

Re: Need help with my xv920

PostAuthor: Jake » Fri Sep 11, 2020 8:24 am

1st off, a visual check of connections, will not suffice. The battery cables should be disconnected and scraped or sandpapered shiny as well as the battery terminals.

2nd point, your battery is overcharged or nearly so. You need to check your R/R to assure the proper charging voltage.
_______________________________________________________________________
“It ain’t what you don’t know that gets you in trouble.
It’s what you know for sure that just ain’t so.”

~Mark Twain


Mustang saddle, Yamaha driving lights, Red rear signals, Forward Controls,
XVS650 manual petcock, Hard Krome Double D exhaust.
User avatar
Jake
Mod
Mod
 
Posts: 13081
Images: 108
Joined: Wed Jun 06, 2007 3:18 pm
Location: Penn's Forestland otherwise known as Pennsylvania Flag
Bike year & model: 1996 XV750
Sex: Male

Re: Need help with my xv920

PostAuthor: Mega778 » Fri Sep 11, 2020 9:21 am

Thanks Jake, please forgive me, I'm very new to bikes, what is r/r?

Mega778
Junior Membership
Junior Membership
 
Posts: 7
Joined: Fri Sep 11, 2020 12:09 am
Location: British Columbia Flag
Bike year & model: 1982 yamaha virago xv920
Sex: Male

Re: Need help with my xv920

PostAuthor: Mega778 » Fri Sep 11, 2020 9:30 am

Nevermind, did some reading. You mean the rectifier and regulator. Ill start there, thanks again.

Mega778
Junior Membership
Junior Membership
 
Posts: 7
Joined: Fri Sep 11, 2020 12:09 am
Location: British Columbia Flag
Bike year & model: 1982 yamaha virago xv920
Sex: Male

Re: Need help with my xv920

PostAuthor: Cusstout 1100 » Fri Sep 11, 2020 11:17 am

Make sure the R/R is well grounded. Many of us here have added a heavy (12 ga. or better) ground wire - from one of the bolts that fasten it to the bike - directly to the frame and negative post of the battery.
My Ride, '97 XV1100, +14, 10" over forks, progressive rear, Jardine forward controls, cobra slip-ons, K&N Filter, Dyno Jet Stage 1, Kuryakin grips, heat demon heaters, custom fabricated seat, chrome side covers, bullet signals, risers, custom modified rear fender with modified FZ1 tail light, sectioned and reversed front fender, custom paint...

Image

Cusstout 1100
Silver Membership
Silver Membership
 
Posts: 1091
Images: 7
Joined: Mon Oct 17, 2011 4:37 pm
  Flag
Bike year & model: 1997 xv1100 Virago
1987 xv535 Virago
1985 xv1000 Virago

Re: Need help with my xv920

PostAuthor: Flyingdog » Fri Sep 11, 2020 1:37 pm

Mega:
:VTF:

Just to elaborate on what Cusstout said so you know "why". Reason being, R/Rs get very hot (so don't freak if you happen to touch it after a ride)... and besides making sure it's "well grounded", this extra wire will also act as a heat sink. While it's not necessary to run the wire to the battery, you can if ya want. Any frame bolt will work fine. To me it's kinda like how people like run an extra ground from starter's mounting bolt to battery. Totally not necessary if ya keep all the ground connections clean/tight in the first place. But maintenance is usually the last thing one does...until something gives out and/or breaks.... :bg:
User avatar
Flyingdog
Silver Membership
Silver Membership
 
Posts: 3414
Joined: Fri Jun 23, 2017 2:31 am
Location: Colorado Flag
Bike year & model: 1985 xv1000 Virago
1981 xv750 Virago
Sex: Male

Re: Need help with my xv920

PostAuthor: Mega778 » Fri Sep 11, 2020 3:47 pm

Thanks everyone, your help is much appreciated. I'm new to all of this (which I'm sure you've seen time and time again) and I have no doubt you've answered these types of questions a thousand times.
I bought the bike and it road very well for a while and now its been one thing after another. My ignition just went as well (my bike turns into a Christmas lighting show with the ignition on) . Turns out sourcing parts like 10a 12v 25mm fuses and the like, for this bike isn't all that easy. Especially post covid.
I have no doubt ill be asking all kinds of questions in the coming weeks.

Mega778
Junior Membership
Junior Membership
 
Posts: 7
Joined: Fri Sep 11, 2020 12:09 am
Location: British Columbia Flag
Bike year & model: 1982 yamaha virago xv920
Sex: Male

Re: Need help with my xv920

PostAuthor: Cusstout 1100 » Sat Sep 12, 2020 12:44 pm

Ahh, British Columbia you say; welcome from a fellow Canuck in North-Western Ontario!

Most basic electrical stuff like fuses, etc. are available at Canadian Tire or NAPA, or other automotive parts outlets. You can use "Partzilla" https://www.partzilla.com/catalog/yamah ... 982/xv920j
to source part numbers that you can take to your local Yamaha dealer, or to search Ebay, etc. for other parts - some are "no longer available" for the older bikes, but good used ones can be sourced, sometimes through this site, and there's always someone here who will help you find what you need.

You're at the right place to get the help you need.
My Ride, '97 XV1100, +14, 10" over forks, progressive rear, Jardine forward controls, cobra slip-ons, K&N Filter, Dyno Jet Stage 1, Kuryakin grips, heat demon heaters, custom fabricated seat, chrome side covers, bullet signals, risers, custom modified rear fender with modified FZ1 tail light, sectioned and reversed front fender, custom paint...

Image

Cusstout 1100
Silver Membership
Silver Membership
 
Posts: 1091
Images: 7
Joined: Mon Oct 17, 2011 4:37 pm
  Flag
Bike year & model: 1997 xv1100 Virago
1987 xv535 Virago
1985 xv1000 Virago

Re: Need help with my xv920

PostAuthor: Mega778 » Wed Sep 16, 2020 7:43 pm

Thanks for the warm welcome cusstout. I'm originally from Ontario. Love that province.

Mega778
Junior Membership
Junior Membership
 
Posts: 7
Joined: Fri Sep 11, 2020 12:09 am
Location: British Columbia Flag
Bike year & model: 1982 yamaha virago xv920
Sex: Male



Post a reply


  • Advertisement

Return to Virago Help - Electronics

Who is online

Registered users: Lufeco